Wie kann man in Excel Namen zählen?

Wenn Sie In Excel Namen zählen möchten, hilft die Funktion „=ZÄHLENWENN()“,. Wir zeigen Ihnen wie es funktioniert.

Mit der Funktion „=ZÄHLENWENN()“ können Sie in Excel Namen zählen. Diese Funktion gehört zu der Kategorie statistische Funktionen. Sie wird verwendet, um Daten in Zellen zu zählen, die ein bestimmtes Kriterium erfüllen.

So wenden Sie die Funktion „=ZÄHLENWENN()“ richtig an

Verwenden Sie folgende Syntax:

=ZÄHLENWENN(Bereich;Suchkriterium)
  • Bereich: Wählen Sie den Tabellenbereich Ihres Arbeitsblattes aus, der alle Namen enthält. Am einfachsten ist es, wenn Sie den Bereich mit der Maus markieren. Alternativ geben Sie den Startpunkt und Endpunkt des Zählbereiches (getrennt durch einen Doppelpunkt „:“) ein. Um eine ganze Spalte in die Zählung einzuschließen, geben Sie die Spalte als Wert an. Beispielsweise um die ganze Spalte A zu zählen, geben Sie „A:A“ ein.
  • Suchkriterium: Das Suchkriterium definiert den Wert, nach dem Excel suchen soll, also den Namen, den Sie zählen möchten.
  • Semikolon: Das Semikolon dient dazu, die verschiedenen Teile der Funktion zu trennen. Beachten Sie dabei: Je nach der Excel-Spracheinstellung kann das Trennzeichen variieren. Während so bei deutscher Spracheinstellung das Semikolon gebraucht wird, wird bei englischer Spracheinstellung ein Komma verwendet.

Drei Methoden

Es gibt indessen, drei verschiedene Möglichkeiten, um Namen in Excel zu zählen. Je nachdem, ob Sie nach einem exakten Namen, dem Teil eines Namens oder mehreren Namen gleichzeitig suchen möchten, unterscheidet sich die Eingabe der Funktion.

Im Folgenden haben wir ein Beispiel für Sie vorbereitet, durch welches wir Ihnen alle drei Methoden vorstellen werden. Wir machen dies anhand einer kleine beispielhafte Namenstabelle.

Excel Namen zählen: Auflistung der Namen & des Alters verschiedener Personen.
Auflistung der Namen & des Alters verschiedener Personen.

Möglichkeit 1: Zellen mit exaktem Namen zählen

Durch folgende Formel können Sie die Anzahl der Zellen in der Spalte A zählen, die den genauen Namen „Jasmin Frei“ enthalten:

=ZÄHLENWENN(A2:A14;"Jasmin Frei")
Anwendung der Funktion um einen genauen Namen zu zählen.
Anwendung der Funktion um einen genauen Namen zu zählen.

Wie wir also sehen können, gibt es in unserer Tabelle zwei Zellen, die den genauen Namen „Jasmin Frei“ enthalten.

Möglichkeit 2: Zellen mit Teilen von Namen zählen

Durch folgende Formel können Sie die Anzahl der Zelle in der Spalte A zählen, die an einer Stelle im Namen „Müller“ enthalten.

=ZÄHLENWENN(A2:A16;"*Müller*")
Formel für die Suche nach der Anzahl des Namensteils
Formel für die Suche nach der Anzahl des Namensteils „Müller“.

Wie wir also sehen können, gibt es in unserer Tabelle drei Zellen, in denen an einer Stelle im Namen „Müller“ vorkommt.

Excel unterstützt in diesem Fall auch so genannte Wildcards (*). Das heißt, vor und nach dem Wortteil „Müller“ darf beliebiger oder auch gar kein Text vorkommen.

Möglichkeit 3: Zellen mit einem von mehreren Namen zählen

Mit folgender Formel können Sie die Anzahl an Zellen in der Spalte A zählen, die „Frei“ oder „Maier“ an einer Stelle im Namen enthalten.

=ZÄHLENWENN(A2:A16;"*Frei*")+ZÄHLENWENN(A2:A16;"*Maier*")
Excel Namen zählen: Formel zum Zählen der Anzahl des Namenteils
Formel zum Zählen der Anzahl des Namenteils „Frei“ oder „Müller“.

Wie wir also sehen können, gibt es in unserer Tabelle fünf Zellen, die entweder den Namensteil „Frei“ oder „Müller“ an einer Stelle im Namen enthalten.

Vorsicht allerdings – der Doppelname „Frei-Müller“ würde auch doppelt gezählt werden!

Verwechslungsgefahr der Funktion „=ZÄHLENWENNS()“ und „=ZÄHLENWENN()“

Fehler können sich sehr leicht einschleichen wenn Sie irrtümlich die Funktion „=ZÄHLENWENNS()“ anstatt der Funktion „=ZÄHLENWENN()“ verwenden. Beide Funktionen sehen sich zwar zum Verwechseln ähnlich, erfüllen jedoch einen unterschiedlichen Anwendungszweck.

Während die erstgenannte Funktion verschiedene Attribute in einem oder in verschiedenen Bereichen in die Auswertung miteinbeziehen kann, zählt die zweitgenannte Funktion die Zellen, welche eine Bedingung in einem festgelegten Bereich erfüllt.



FavoriteLoading Tipp meinen Favoriten hinzufügen (setzt Cookie, mehr unter Datenschutz)